【PocketMine】0.14.0対応方法


どうもこんにちは、最近この冒頭文のネタすら無くなりかけているヨッシーです(汗)

 

先日、とある別の方が書いた「Minecraft PE 0.14.0対応方法だとエラーが出る」と言われてこちらでも書くことにします。

image

今回の実行環境

GNU/Linux CentOS 7.2

VPS: ConoHa

src: NIGHTMARE(ナイトメア)

 

〜準備するもの〜

VPSの場合

  • SFTP対応クライアントソフトウェア
  • 0.13.2時代のsrc or 0.14.0のsrc

 

パソコン(WindowsやMacなど)の場合

  • テキストエディタ
  • 0.13.2時代のsrc or 0.14.0のsrc

では始めていきましょう。

 

手順①

/src/pocketmine/network/protocol/Info.php

image

const CURRENT_PROTOCOL = 38;

の「38」を、「45」に書き換えましょう。

 

手順②

/src/pocketmine/PocketMine.php

を開き、75〜79行目あたりから
const VERSION = '1.7dev';
const API_VERSION = "1.13.1";
const CODENAME = "[NIGHTMARE]";
const MINECRAFT_VERSION = "v0.13.2 alpha";
const MINECRAFT_VERSION_NETWORK = "0.13.2";

 

このコードを、
const VERSION = '1.8dev';
const API_VERSION = "1.14.0";
const CODENAME = "[NIGHTMARE]";
const MINECRAFT_VERSION = "v0.14.0 alpha";
const MINECRAFT_VERSION_NETWORK = "0.14.0";

 

に書き換えましょう。

これで対応は終了です!

 

start.cmd、もしくはstart.shを起動してPocketMineの動作を確認しましょう。

最近ではGenisysやImagicalMineなど、srcによって非常に大きな違いが出てくるようになりました。

今回はNIGHTMAREで行いましたが、他srcでの動作は保証いたしません。


 

関連サイト

 

PocketMine-MP Official Web

【Windows】PocketMine PHP7対応してみよう

PocketMine用語集

日本製のPHP7対応src『iPocket』

Yossi1114

どうもこんにちは、このサイトの管理人のよっすぃーです\(へωへ)/

【PocketMine】0.14.0対応方法” への1件のフィードバック

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です